All Articles Logic Pro
故障排除101:没有音频输出逻辑?没问题!
Rounik Sethi on Thu, May 27th | 17 comments
Logic is a wonderfully deep, creative piece of software! There's no doubt about that...  It has steadily become easier to setup and use since Apple acquired it from Emagic But, as any software user .

逻辑是一个奇妙深刻的,创造性的软件!毫无疑问... ...

所以,你可以做什么?好了, 教程论坛往往是大多数人的第一停靠港。但如果你想自己尝试诊断问题呢?你不需要是一个高科技的天才解决了一些问题... ...配备自己的工具箱

Logic用户所遇到的比较常见的问题之一是,当你不能得到任何声音输出从逻辑项目。与否的问题是用户错误(它发生在我们最好的!),基于硬件(音频接口,控制面,显示器,电缆,坏的RAM ...),或软件bug或功能,这些技巧将帮助您诊断它,了解它,并最终解决它!

我建议你​​阅读下面这些技巧,即使你从来没有遇到过这样的问题在逻辑。


提示1 -检查你的硬件

的“根”的第一步是检查您的音频接口是否连接正确,连接的FireWire / USB电缆从界面到Mac,如您的显示器和耳机所有电缆是否连接正确。确保提出适当的音量,在这一点上,它的一个好主意,检查电缆是否OK。他们交换。如果你不能交换它们(你没有任何备件?),那么你可以回来到了这一步。

你也应该检查是否已为您的音频接口和相关的硬件制造商的网站上提供最新的驱动程序。总是在安装前,他们与您正在运行的逻辑和OS X的版本兼容的驱动程序(S)检查。


秘诀2 -音频MIDI设置

音频MIDI设置允许您设置MIDI和音频设备连接到Mac。这是一个好主意,检查这个小应用程序。它位于您的应用程序/实用工具“文件夹

选择“ 窗口”


秘诀3 -输出设备安装

另外一个很好的测试,以确保声音是你的Mac,例如iTunes的其他应用程序...但是,一旦我们已经建立了,你的Mac的音频播放的罚款,它的时间逻辑。

In Logic choose Logic Pro > Preferences > Audio

Under the Devices tab, you should see the Core Audio tab (which should be enabled).

在核心音频,你会发现输出设备和输入设备。确保这些都设置为您的音频接口适当。

在上面的图片,我有我的远地点为输出和输入设备的二重奏设置如果你有一个音频接口选择它。如果没有,请使用你的Mac的内置输出作为输出设备。


秘诀4 -检查你的通道

在逻辑打开搅拌机,确保通道条输出传送到立体声输出,或者如果你是通过总线路由,相应的辅助通道,是开始路由到输出​​。

在上面的图片中,我们能够确定某些信息:

  • 声音正在注册和逻辑的内部音频引擎的通道条上发挥。
  • 从每个通道地带的信号被直接发送到输出通道的地带。
  • 输出通道条没有被静音,我们可以看到它的电平表活动。
  • 没有仪器(Ultrabeat能,EXS24,EVP88,等),旁路(变灰)。
  • 主通道带既不是静音的,也不是它的足够低的水平,我们可以听到从逻辑输出。


提示5 -检查静音和独奏的

有不同的方式在逻辑静音和独奏。这是可能的静音/独奏通道条的水平,跟踪水平,地区水平甚至MIDI​​事件(例如一个单独的MIDI音符)。

在下面的搅拌机图片,我有一个独奏模式下的单一渠道地带,所以从其他渠道到达输出信号将被停止。你可以告诉在这种情况下,静音按钮会闪烁。

如果由于某种原因你不能找到独奏通道地带,无论是在调音台所有选项卡上单击,手动搜索,或 Option键任何通道的独奏按钮两次。任何通道条,将在现在的独奏模式。


提示6 -单独排列

当你在安排当地不妨独奏一个地区或区域集团,同时安排或混合。大多数用户达到在运输的单独按钮或选择一个区域,然后 S键。

选定的区域显示为黄色边框。然而,如果您取消一个地区安排当地的背景上点击你将听不到任何声音,因为从你的项目没有一个区域选择和逻辑仍然在单独模式。


The solution is to check the solo button in the transport is off. If for some reason you've removed it from the Transport, you can tell when solo mode is active as the Bar Ruler is highlighted in yellow.


秘诀7 -检查自动化

它可能已在您的项目的书面静音或独奏自动化。选择查看

您可能还希望检查您的自动化值的立体声输出通道... ...首先,您需要将它添加到安排当地的,因为默认情况下不会显示在AUX和输出通道条排列区域。

打开混频器, 右键单击输出通道地带,并选择创建 /从下拉菜单中选择排列曲目。


秘诀8 -试听频道地带

试听通道条逻辑是用来预览的Apple Loops和样品编辑器中正在播放的音频地区。

它通常保留对音频通道地带256。打开搅拌机,并在右上角点击“ 全部 ”选项卡上。滚动,直到您找到试听通道。

现在,打开循环浏览器,点击任何循环。您应该会听到一些逻辑,并通过音频接口的音频。如果仍然没有声音,从项目的其余,检查的独奏和静音按钮...


秘诀9 -检查你的立体声输出 ... (!)

这是一个有趣的,macProVideo.com逻辑论坛的用户带来了我的注意。如果你误删的环境中的立体声输出通道条或混频器,你会从你的项目没有听到任何音频,除非你是不同的输出音频路由...

为了解决这个问题,开放的环境和导航到混频器层。这里选择新建

再次,你应该听到声音输出从您的项目!


提示10 -最后的想法

这是不寻常的,但不是闻所未闻的,一个项目可能会损坏。在这种情况下,尝试建立一个全新的项目,并使用试听

Logic saves backups of your project file in the Project folder/ Project File Backups sub-folder.
Try opening one of these to see if your project can be recovered. If it can, save as a new project to a new location with a new name and continue working on that version.

你知道,我不会让你走,直到我谈到有关备份您的重要文件。因此,备份...像碳克隆复制或超级骗子或Time Machine来备份你的整个系统使用一个应用程序...或复制到一个外部驱动器或到DVD的重要文件。

最后,这里的一些实用的保养程序,可以帮助 - 和他们绝对不会伤害... ...! OS X的故障排除三位一体:

  1. Restart your Mac (quit all applications and choose Apple Menu > Restart...)
  2. Repair Permissions (check out this thread on how to repair permissions on the Mac)
  3. Trash/remove the Logic Preferences file: Go to User Home folder/Library/Preferences/Logic/  and move the file: com.apple.logic.pro.plist  to the Desktop. Restart Logic...

配备所有上述逻辑的故障排除提示,你不仅能找出一些常见和不常见的“无声音”在逻辑问题,但你来逻辑大师所有的朋友。

Interested in learning more about Logic? These tutorials will help you to become proficient whether you are starting out or looking for advanced tips, tricks and techniques! We'd love to hear your tricks, shortcuts & opinions. Let us know what you think by writing a comment below!

Comments (17)

You must be logged in to comment. Login Now

  • I'M STOP TO READ AT TIP 3!! i think that this is the problem, i've shoot a photo to explain better: http://img822.imageshack.us/i/schermata20101019a21560.png/ what i have to do?!?...it's a serious problem?!?
    • 8 years ago
    • By:
    Reply
  • Rounik Admin
    Hi Scott, That's a good one to add! Checking that the Stereo Output's... output is set appropriately.
    • 8 years ago
    • By: Rounik Admin
    Reply
  • Rounik Admin
    Hi Pietrod, I see from your screenshot that you are using Logic 8. That's fine, but my image looks different because of this. If you are not using a 3rd party audio interface (like an Apogee Duet, Presonus Firebox, etc) then choose Built-in as your Device. Please continue reading the rest of the article. If you still cannot get any audio output from your project please contact me via the macProVideo forums here: http://www.macprovideo.com/forum/logic/logic-pro-express Thanks Rounik
    • 8 years ago
    • By: Rounik Admin
    Reply
  • on right a go on in the reading of the article then i wll know you if it works... thanks, for no now!! bye bye
    • 8 years ago
    • By:
    Reply
  • Rounik Admin
    Good luck Pietro! :)
    • 8 years ago
    • By: Rounik Admin
    Reply
  • hello....sig i'm read the 4 and 5 tip, and the bar don't move also went i use the keyboard!! so i've try to create a new one (in the tip 9), but i HAVEN'T THE BUTTON: http://img811.imageshack.us/img811/5135/schermata20101022a15231.png WHAT I HAVE TO DO.....!! I HAVE DOWNLOADED THE WRONG CODE?!?!?
    • 8 years ago
    • By:
    Reply
  • Rounik Admin
    Hi Pietro, It's difficult to know what's happening for you in tip 4/5 without seeing your Arrange window too. Everything looks OK in the Mixer, except that Audio 3 is muted... e.g. 1. do you have any AUDIO regions on the audio tracks/channel strips? 2. Can you hear the metronome if you select it (K) and press play (space bar)? 3. Open the Loops Tab and select a loop, can you hear it? I'll need a bit more information to help you.... 4. What exact versions of Logic and OSX are you running? 5. Are you using an external audio interface / sound card? Which one? 6. What do you mean "I HAVE DOWNLOADED THE WRONG CODE?!?!?" I don't understand what "code" you mean. 7. If you re-launch Logic and open a brand new template and click on a loop in the Loop Browser, do you hear any sound at all? 8. Have you heard from sound output from Logic before... or is this your first time using Logic? Thanks Rounik p.s. It might be easier to troubleshoot your issue on our Logic forums. If you like to, then you can start a new thread there: http://www.macprovideo.com/forum/logic/logic-pro-express
    • 8 years ago
    • By: Rounik Admin
    Reply
  • this is the first time, ooo, yes i heart the loop, thank you...so the problem is more complex...mmmm but i can't heart the metronome - i'm not sure, maybe i haven't start it... i have no external audio cards.. i have the last version of OS, with code i mean program, but it's a joke... yes, maybe i will ask to the forum, but, can you help me via skype with sharing sceen?!!? so in a few minutes i resolve the problem.....i'm donpietrod...if you can (if you vote for obama you can.....ehehe)
    • 8 years ago
    • By:
    Reply
  • Rounik Admin
    Hi Pietro, Sorry I don't have time to help everyone by skype (for free ;)... But seriously, start a new thread on the forums and I'll be there to help you. An even better solution is to invest in this Logic 101 macprovideo tutorial: http://www.macprovideo.com/tutorial/logic9101 Which will take you through Logic from the very beginning step by step. There's a discount now on for 33% off on any tutorial download with this code: http://www.macprovideo.com/cart/code/10GreenSaleExt33 It's good until 27th October... but whether you purchase the tutorial or not, let me know here or on the forums how you are getting on. The first big question I must ask you is what are you trying to do in Logic - that you think it's not working?? And have you seen these beginner blog guides (free) that I wrote: Part 1: http://www.macprovideo.com/blog/logic-pro/complete-beginners-guide-apple-logic-9-part-1 Part2: http://www.macprovideo.com/blog/logic-pro/complete-beginners-guide-apple-logic-9-part-2 Hope this helps :) Rounik
    • 8 years ago
    • By: Rounik Admin
    Reply
  • Harlz
    THANK YOU for your expertise!!!!!! Honestly I have been battling Logic Express 9 not communicating with my M-Audio randomly for quite some time...Mostly just gave up and tried again days, weeks, and sometimes months later. This one post changed my life "Repair Permissions"....Who knew...well you did. Can't express how freeing this has made my recording time... I can finally accomplish something. KUDOS Mr. Sethi
    • 9 months ago
    • By: Harlz
    Reply
  • I seem to have trouble getting an input signal. I use fast track and it works in garage band (after I go mono, monitor on - and I have preferences inout as fastrack, output as inbuilt output. At least I know my equipment is fine - Iopen up logic (using same in and out put preferences) I click on I and I get no input signal. Any ideas?
    • 8 years ago
    • By:
    Reply
  • Rounik Admin
    Hi Jason, Did you also try clicking on the audio track's "R" button so it turns red? Do you hear any input from your Fast track then? Is the Input on the audio channel strip in Logic set to the correct input on your Fast track? e.g. "Input 1"
    • 8 years ago
    • By: Rounik Admin
    Reply
  • Rounik Admin
    oh, also do you have "Software Monitoring" turned on in Logic's Preferences?
    • 8 years ago
    • By: Rounik Admin
    Reply
  • when i try to record or use my computers keyboard as the keyboard, all that comes out of my speakers is a very high-pitched whine. it is very irritating
    • 8 years ago
    • By:
    Reply
  • One more item to check: I had a "no output" problem that defied, well, Logic. Old Logic files and GB files as well would load, with no output to the stereo bus. Individual tracks were registering signal, and all the routing was set properly. Turns out I had a plugin selected that required reauthorization. The only symptom was no output from the mains. Frustrating.
    • 8 years ago
    • By:
    Reply
  • Hello :) I have a problem, of course. I am recording audio from a Behringer Xenyx X1204USB so i have a USB input, but that is not the problem. The thing is that in Logic Pro 9 i can see the audiowaves in the track i can see (i mean the program shows me) the volume levels going up and down everytime i play a loop or a recording but the audio doesn't come out of the speakers (built-in) nor the headphones... So basically I can't hear the audio and to add up i did all the steps from above and still nothing... I would appreciate very much if you could help me :) Thanks, Octavian
    • 6 years ago
    • By:
    Reply
  • Rounik Admin
    Hi Octavian, Excuse the late reply. 1. Do you have the Behringer setup as the output in Audio Preferences? 2. On your Behringer device is there an output level control which control volume? 3. Switch to built-in output... can you hear sound coming from your Mac? 4. Is the Master Output fader in Logic's Mixer at a healthy level? (0.0dB). 5. What exact version of Logic are you using? 6. What version of OS X are you running? 7. Can you hear sound output from Logic if you start a brand new project?
    • 6 years ago
    • By: Rounik Admin
    Reply
Feedback
Course Advisor
Don't Know Where To Start?
Ask A Course Advisor
Ask Us!
Copy the link below and paste it into an email, forum, or Facebook to share this with your friends.
Make money when you share our links
Become a macProVideo.com Affiliate!
The current affiliate rate is: 50%
Classes Start Next Week!
Live 8-week Online Certification Classes for: