macProVideo.com
Forums
  • adamski
    Posts: 11
    Joined: Jun 5th, 2007
    midi sync issue
    im having issues with any midi hits/notes drawn in sound out when i play it back so i record midi to audio then zoomed in to confirm. what ive just realized is the problem exists using any plugin like massive, fm8, or anything in reason when in rewire, eg when i draw in 4 midi hits on the beat using redrum then record that clip to an audio clip in live i then zoom in on the warp markers to find all the hits are late however when i use impulse everything is spot on? hopefully this will help in narrowing down what the problem is being caused by
    Reply
  • Christian L
    Posts: 1423
    Joined: Aug 7th, 2006
    Re: midi sync issue
    Hi, Do you experience this issue in all your project ? What version of Ableton Live are you using ? Christian
    Reply
  • adamski
    Posts: 11
    Joined: Jun 5th, 2007
    Re: midi sync issue
    yes in any project? im running the latest version of live, reason, the latest driveres for the m-audio fast track pro and the latest software for the novation remote sl.... it is effected when using any 3rd party plugin such as massive, fm8 etc or any of reasons instruments when in rewire, reason plays fine on its own , the midi clip also plays in time without the hits landing late if i use impulse? the way im checking this is recording any of the midi clips to audio then zooming in on the warp markers in the audio clip - the hits all land late for any of the 3rd party plug ins or reason in rewire - ive also just tried programming the midi in reason but the issue is still there.
    Reply
  • Christian L
    Posts: 1423
    Joined: Aug 7th, 2006
    Re: midi sync issue
    That's strange... never heard of this before. You could try lowering the buffer size under Live > Preferences > Audio Device. Is there any lag when you play notes on your MIDI controller or is it only in playback ?
    Reply
  • adamski
    Posts: 11
    Joined: Jun 5th, 2007
    Re: midi sync issue
    its when i play the notes back its out by the same amount on each hit? ive tried using external device plug in and also adjusting buffer size as well as track pre/delay and compensation delay....cant really do much at the moment as i have to record the midi to audio then warp to get it sounding tight.
    Reply
  • adamski
    Posts: 11
    Joined: Jun 5th, 2007
    Re: midi sync issue
    ok ive tried a couple of things to help us narrow this down, first of all ive adjusted the predelay to -13.1ms, (vst in live)if i then drag massive in and draw in 4 16th bass hits on the beat then record the midi to audio with the monitor off on the audio track the hits are on. (reason in rewire) if draw in 4 midi kick drum hits to go across to reason using external instrument plugin on the midi track and have the monitor switched off when i then record the midi to audio the beats from reason are in line with the warp markers also. is this how it should run?
    Reply
  • adamski
    Posts: 11
    Joined: Jun 5th, 2007
    Re: midi sync issue
    man something so simple, turned out i had the wrong input selected on the audio channel i was recording the midi from, had ext in instead of external instrument channel itself selected . all good now
    Reply
  • Christian L
    Posts: 1423
    Joined: Aug 7th, 2006
    Re: midi sync issue
    Great! Thanks for posting the solution! :-)
    Reply
You must be logged in to post a reply
Subscribe to receive an email for each new post on this thread. Please login
Recent Threads
Recent Posts
Feedback
Course Advisor
Don't Know Where To Start?
Ask A Course Advisor
Ask Us!
Copy the link below and paste it into an email, forum, or Facebook to share this with your friends.
Make money when you share our links
Become a macProVideo.com Affiliate!
The current affiliate rate is: 50%
Classes Start Next Week!
Live 8-week Online Certification Classes for: