macProVideo.com
Forums
  • BeastCoast
    Posts: 4
    Joined: May 23rd, 2014
    RX8 Plugins crashing on open
    Does anyone have any issues with RX8 plugins crashing when you open them on your channel strip? It seems this problem has begun after the most recent Logic 10.6 update -- but I can't be positive. All I know now is that I open Deess, Declick, or any of those plugins, and logic instantly crashes. So I first found an article about RX8 crashing and made sure none of the 3 plugins they listed were being used on the same channel strip, but that didn't work. Then I reinstalled RX8 from my Izotope product portal, but that didn't work either. Any help would be appreciated!
    Reply
  • Joe A
    Posts: 1380
    Joined: Oct 1st, 2013
    Re: RX8 Plugins crashing on open
    I haven't experienced that, but I'm still on Logic 10.5.1. You might want to check to see if iZotope has an update to RX and the plug-ins, though if it is a Logic 10.6-related issue it might take a little while for them to catch up. If you backed up your copy of Logic 10.5.1 I guess you could still work in that whenever you really need to use those particular plug-ins.
    Reply
You must be logged in to post a reply
Subscribe to receive an email for each new post on this thread. Please login
Recent Threads
Recent Posts
Feedback
Course Advisor
Don't Know Where To Start?
Ask A Course Advisor
Ask Us!
Copy the link below and paste it into an email, forum, or Facebook to share this with your friends.
Make money when you share our links
Become a macProVideo.com Affiliate!
The current affiliate rate is: 50%
Classes Start Next Week!
Live 8-week Online Certification Classes for: